Creating insight error message

  • 5 June 2023
  • 7 replies

Whenever I try to add a new insight onto a dashboard I keep getting this error message: refused to connect. Does anyone have any ideas how to resolve this? I have tried multiple devices and browsers




Best answer by JVAJ 12 June 2023, 21:57

View original

7 replies

Userlevel 3

Hi James,

Sorry to hear so. I was unable to replicate the issue in my own cloud environment.
Does it happen also when you are working with a brand new dashboard or does it affect just existing dashboards, please?
Please be so kind and check if you are not breaching one of our GoodData Cloud Limits Follow.

It happens on both new and already created dashboards. It also happens when I got to edit an already created insight. It is a trial account with a relatively small import of data and a simple dashboard so I doubt we have exceeded limits.

Userlevel 3

Thank you for the clarification. I can confirm, there was/is not global GD Cloud issue, which might be causing such behaviour.
Is this issue affecting just one particular workspace or does it affect multiple of them?
Also, are you aware of some recent model changes, please?

I have added a small amount of extra data onto one data source, but at the same time removed significantly more so it is unlikely that is the issue. It is across all dashboards and workspaces - even the demo workspace.

Userlevel 3

Hey James,

Thank you for additional details. I've check the LOG and noticed some records indicating issues with token refreshment.
Could kindly try to clear your cache and cookies and relaunch your GD Cloud instance, please?

Userlevel 3

Hi again,

one more thing to add here. I'd like to do some investigation on my end in the meanwhile. Could you kindly try to replicate the issue and check your DevTools when the error appears, please?

If possible, collect a HAR file for us as navigated for example here and send it to our email address

Many thanks in advance.



this problem can happen, when you are fiddling with Content Security Policy ( and forget to include your endpoint ( in the “frame-ancestor” setting. 

You can either add it there or completely remove (depends on your case).