Solved

Migrate Computed Attributes between Workspaces

  • 10 April 2023
  • 5 replies
  • 39 views

  • Known Participant
  • 20 replies

Hi,

 

I'm trying to migrate computed attributes from STG to PROD workspaces, but after step 6 (attached link below), I'm unable to proceed because it is not providing any scripts.(Please find the attached screenshot)

https://help.gooddata.com/doc/enterprise/en/workspace-and-user-administration/managing-workspace-data-and-data-access/manage-attributes/use-computed-attributes/

Environment: Gooddata Platform

Please help me on how to resolve this.

 

Thanks,

Kavi

 

icon

Best answer by Francisco Antunes 10 April 2023, 16:13

View original

5 replies

Hi Kavi,

Thanks for putting this in. Thank you for the screenshot and the detailed description of your steps, too. They were much appreciated! I was able to reproduce the exact message you got on my own testing environment.

The Poll message you got occurs when you copy the JSON structure but instead of pasting it on the Target workspace (Step 4), you pasted it on the Source workspace itself. Please take a second look at Step 4 of the article and make sure that you update the endpoint there to match the Target (in this case, PROD) workspace ID. The scripts should generate correctly then.

Let me know if this does not resolve your issue and we’ll continue to investigate.

 

Best,

Francisco

Hi Francisco,

 

I made sure that the target workspace was the only place where I pasted.

 

Thanks,

Kavi

Hi Kavi,

Thank you for confirming you were pasting on the correct workspace! I did some additional checking from my end.

The  endpoint you are using on the Target workspace, “projectmodelDiff”, produces a script based on the differences between the two projects (in their computed attributes). The output you received (which I replicated by using the Source workspace twice) means that the tool found no difference between the two workspaces; thus, it cannot create a script to amend these differences.

Would you kindly provide a bit more detail about the task at hand? What kind of changes you are trying to propagate? Have you use this feature successfully in the past? Has anything changed in your environment?

Could you please confirm the computed attributes are not already present on the target workspace, too, just to be sure?

Also, note that the procedure from the article is not required if you have the LCM features enabled on your environment, as the LCM bricks already migrate the computed attributes automatically (which would also lead to the message you received).

 

If the issue still persists, we might need to directly investigate your workspaces for more details. We will let you know how to proceed in that case.

 

Best regards,

Francisco

Hi Francisco,

If the dashboards for the source and target are identical, why am I encountering the following problem when migrating the KPI dashboard?

Thanks,

Kavi

Hi Kavi,

Thank you for the additional details and for confirming that the Diff might not be accurate, in this case.

At this point in the case we will need some more specific information to continue investigating, so it’s best for us to proceed elsewhere. We will be in touch with you directly via email very soon with the next steps.

 

Thank you!

Francisco

Reply