Solved

Can't create Insights, results cache crashing

  • 26 August 2021
  • 2 replies
  • 75 views

Now that we setup our data source (BigQuery), the LDM can be built fine, first insights could also be created and saved, but after a few minutes of usage, any query prompted by the Report Designer would have the following result: 

This also happens when trying to load previously saved insights.

 

Looking under the hood, it turned out the results cache keeps crashing:

pod/gooddata-cn-result-cache-c8f8f9cb9-8l9ps               0/1     CrashLoopBackOff   7          20m
pod/gooddata-cn-result-cache-c8f8f9cb9-mlcc2 0/1 CrashLoopBackOff 7 18m
NAME READY STATUS RESTARTS AGE

I have attached the log output, any help is appreciated!

icon

Best answer by Robert Moucha 27 August 2021, 10:51

Hi,

its caused by too many cells generated during data transformation of your result (882500 cells) and this value won’t fit to memory of the component result-cache. We plan to limit the results at earlier stage so the OOM should not happen and error will be reported sooner. The root cause is that your report probably contains too many distinct values in some of your dimensions.

 

Now, you may try increasing memory of result-cache by setting this tunables in helm chart (see the defaults we have):

# Defaults from values.yaml, update according to your needs
resultCache:
resources:
limits:
memory: 700Mi
requests:
memory: 400Mi

 

The solution above will not help in all cases, larger result sets may fail, so I suggest to rework your metric to return less distinct values.

Regards,

Robert

View original

2 replies

PS: This morning, the issue was gone, but after ~15 minutes of working with the Report Designer, it came back again. The initial problem seems to be memory-related:

NAME                                                       READY   STATUS             RESTARTS   AGE
pod/gooddata-cn-result-cache-c8f8f9cb9-8l9ps 0/1 OOMKilled 151 16h
pod/gooddata-cn-result-cache-c8f8f9cb9-mlcc2 0/1 CrashLoopBackOff 152 16h

 

Userlevel 1

Hi,

its caused by too many cells generated during data transformation of your result (882500 cells) and this value won’t fit to memory of the component result-cache. We plan to limit the results at earlier stage so the OOM should not happen and error will be reported sooner. The root cause is that your report probably contains too many distinct values in some of your dimensions.

 

Now, you may try increasing memory of result-cache by setting this tunables in helm chart (see the defaults we have):

# Defaults from values.yaml, update according to your needs
resultCache:
resources:
limits:
memory: 700Mi
requests:
memory: 400Mi

 

The solution above will not help in all cases, larger result sets may fail, so I suggest to rework your metric to return less distinct values.

Regards,

Robert

Reply