Hey, everytime I do changes on the data schema, I ...
# gooddata-cloud
Hey, everytime I do changes on the data schema, I get back to the analyze section to retrieve the newly brought columns but cannot find them? Does it take time for the changes to load in the analyze tab?
Hi Menelaos, the changes you make should reflect straight away in the analyze tab. If you didn’t receive any error msg, and after refreshing the analyze tab, they are still not there - Perhaps they are unrelated to some existing facts/attributes you already have in your Insight. Can you please trying to remove all other facts/attributes and then search for the new columns? If this doesn’t help, would you please be so kind as to provide a little more details on the update you’re making and perhaps some screenshots they highlight the issue?
Hey @Michael Ullock, thank you very much for the info. What I did is to update the query here in a table I have, added something an extra in the
section, which was not reflected into the table. Don't know how to update so that it shows the extra field too. I've also exerienced that in the past. What I did was to delete the table and re-create, however that's not feasible anymore since the data schema has grown a lot and the table is already used by different dashboards.
Hi, @Michael Ullock, double checking that you've seen the above.
Hi @Menelaos Kotoglou, sorry for the delay in getting back to you. We were able to replicate this behaviour on our side and we are currently looking into this. Once we have more details, we will reach back out
Good, thanks for that!
The attribute and fact objects are created automatically only for the initial SQL query. You need to add them manually for new columns after editing of SQL statement of SQL dataset and map them to the new columns. You need to save the model and refresh data fields in Analyze after you create new attribute and map it to the new column.
There is +ABC button below the logical objects of the dataset. Other option is to go to details of the dataset and create the field there including the proper mapping to source column in result set of your query
Thank you very much for the help @Jakub Sterba and @Michael Ullock!