Hi, I applied the authentication part as mentioned...
# gooddata-platform
Hi, I applied the authentication part as mentioned here https://sdk.gooddata.com/gooddata-ui/docs/platform_sso.html#sso-is-not-implemented-on-your-site And It worked fine but when redirecting to the react app after logging in (admin user) I'm getting for
Copy code
<InsightView />
Sorry you don't have access to this insight. Login or ask your administrator to grant you permissions.

<iframe />
it works fine and insights are displayed
So any idea how to fix this ?
Hi Mohammad, can you please make sure the user is enabled in the workspace and has enough rights to see the insight? If he does, can you share an error/message ID or send a har file via DM? Thanks.
ok will share with u the error
Hi Mohammad, from the information I've received I think I know where the issue lies. When you use our accelerator toolkit the react app uses simple http proxy to avoid issues with CORS - all requests are proxied between the gooddata environment and the app deployment. However, an successful SSO login returns authorization cookies for your GoodData environment - browser doesn't know it has to use it for authorizing you inside of the app - as the requests are sent to the app's hostname and then proxied to your GD environment. To be able to use SSO inside of your react app, you need to disable the proxy, select correct backend and enable CORS for your GD environment. Based on the type of SSO you are using, following articles should help: https://community.gooddata.com/gooddata-ui-kb-articles-48/gooddata-ui-saml-sso-example-411 https://community.gooddata.com/gooddata-ui-kb-articles-48/gooddata-ui-pgp-sso-example-394
Hi Mohammed, I see that you actually posted a link mentioning flow without SSO. Sorry for missing that. But the issue and it’s resolution is more or less the same - authorization cookies returned by the login are not used, as they are "issued" for different hostname than where you app sends the requests - disabling the proxy and setting up the cors should help.
ok will check
ok so what I did is: • comment the gdc part in the proxy file • run the app and used localtunnel to get https url • used the api to add the url to allowedOrigins now I'm getting different error
Copy code
The insight with this URL does not exist.
And I checked the network tab the reqs error all the same
Copy code
Cannot GET /gdc/account/profile/current
Cannot GET /gdc/projects/***********/styleSettings
It looks like the proxy was correctly disabled - http headers are no longer being manipulated, but the requests are still being send to the hostname of your app - you will need to configure analytical backend (pointing to hostname of your GD environment).
yeah it works now thank u
👍 1