Hello <#C01UR5BGAHY|gooddata-ui> Actually, I am t...
# gooddata-ui
Hello #gooddata-ui Actually, I am trying to run the GoodData UI application. I worked on it a year back. The application is working well. However, I am not able to run the code on my system. Everything was configured correctly when I worked on it a year ago. I just did yarn install followed by yarn run. But, the "yarn run" don't seem to work for some reason, I am getting the following error. Could you please help me resolve this issue?
yarn start
yarn start
is equivalent to
yarn run start
, where
is a script defined in the
file. the
command starts a script, so it needs an extra argument
👍 1
Hi @Gonçalo Teixeira, Even yarn run start isn't working. It is giving me the following error.
Sorry about that, that’s out of my scope now
Hi, it seems to be a problem with the version of NodeJS you are using. We use version 18.17.0 when developing the GoodData.UI, so that one should work. Can you please try using that version?
Hey @Dan Homola This error is still persisting. Now I have installed the lates 18.17.0 node.JS version. However, there is one thing to highlight. When I was doing a yarn install, I got the following warnings, asking for upgrades of the goodData version. But, I am not aware of how can I upgrade the GoodData Versions.
Hello @Dan Homola, PFA my package.json file, If this can provide any inputs.
Hi, yes, the version 7 is no longer supported, please check out the migration guide to version 8 here. In fact, we recently released version 9, but to migrate to it, you first need to be on version 8. In any case, you having the older version of the SDK should not cause this error. Looking at the package.json, it seems you have outdated react-scripts dependency version, some people suggest that version 5.0.0 fixes this very issue. Please check out the react-scripts migration guide to help you upgrade it and hopefully resolve your issue.
If you decide to go for the react-scripts upgrade, I suggest going directly to version 5.0.1, the 5.0.0 had some other issues that might affect you as well
Hey @Dan Homola I have updated all the required dependencies as advised by you. However, I am still facing certain issues. PFA the images. I have even updated the package.json to the latest versions. Please have a look at the .js file as well. Thank you!
Mixing GoodData.UI versions 7 and 8 is discouraged, can you please remove the
dependency? That should reduce the number of warnings quite a lot. As for the browser, are you accessing
? Because only the https version will work.
Also, looking at your package.json you are mixing some packages from GoodData.UI version 8 and some from version 9, can you please unify those to use the same version?
https://localhost:3000/ This is what I am using.
But @Dan Homola, How will I know to which version should I update all the goodData dependencies to? Can you provide me with the updated package.json. If thats possible from your end?
I would start with 8.12.0 for now, you can move to 9.0.0 later
Does the terminal you use to run the
yarn start
output any errors when you do that?
Yes @Dan Homola I am getting the following error. Along with that, I am also getting certain warnings with the packages. There are many such warnings. Should I upgrade all the GoodData versions to 8.12.0?
Waiting for your reply?
Yes, please upgrade all of them to 8.12.0. The error you are getting relates to this part of the migration, please take a look and change the affected code accordingly.