Hello All We are addressing a support ticket from...
# gd-beginners
Hello All We are addressing a support ticket from one of our clients and facing difficulties, we have some doubts that the gooddata documentation has been insufficient to clarify. Our main issue is that our database is running a very heavy query and it may take a few minutes to respond to a request from gooddata, with this, gooddata is throwing a timeout exception, the documentation says that the default timeout is 160 to 170 seconds. We need to increase this timeout time so that the database can process the data and respond to the gooddata request. Increasing the timeout is a temporary solution while we optimize the response time of the database. I am forwarding the gooddata error message and a simple schema of our integration with gooddata to provide more context to the problem.
Hi Lucas, the 160's for sql-executor service is set on our side. However, I am currently reviewing this with our team if this is something that we might be able to change for you. However, in the meantime, have you tried the performance tips mentioned in the documentation? https://www.gooddata.com/docs/cloud/connect-data/create-data-sources/postgresql/ Performance Tips If your database holds a large amount of data, consider the following practices: • Index the columns that are most frequently used for JOIN and aggregation operations. Those columns may be mapped to attributes, labels, primary and foreign keys. • Define partitioning to improve performance of visualizations that use only the recent data. This feature strongly relies on the version of your PostgreSQL Version database, so check the official user documentation for your version.
These performance tips do not apply to our case because we are currently using virtual tables that cannot be indexed. Probably because Ferenta's original tables are already indexed and we no longer have access to this path.
Is there no possibility of increasing the timeout time?
I’m going to discuss this case with our Technical team and will get back to you once we have more details on the options to help with this
Thank you, I'll wait.
Hi Lucas, we cannot increase the timeout as there could be a negative chain reaction in the code used. You will still need to optimize the query on your end. However, we will mark this as product feedback so our engineers can review your request.
🎉 New note created.