Hi I tried Python SDK for cloning workspace via “s...
# gooddata-cloud
Hi I tried Python SDK for cloning workspace via “sdk.catalog_workspace.clone_workspace”, but after clonning, data model is created BUT the mapping is in error for all tables - appears after refresh - but also shown by not working dashboards:
Hello @Markéta Jedličková, Did you call this method with argument
👀 1
Unfortunately, default is
The problem is that naming is camel case and by this option it is overriten - nor uper_case or lower_case is ideal :(
Aha! In that case, could you, please, try
What database do you use?
Most of databases are case insensitive and lower-case by default. Snowflake is the exception - it's upper case by default
Aha, in your case the scanned column names are really camel case. First time I see something like this 😉 What we do - when we generate SQL queries for reports, we enclose table/column names by enclosers valid for the DB, e.g.
. So we force the case - column name in the database must exactly equal to the name stored in GoodData including the case sensitivity.
So, if you execute manually a query against you database using these enclosers and names you can see in GoodData, does it work? If not, what names work and how they differ from what is stored in GoodData?
upper_case=None solved my issue! Thank you a lot 🙂