Hey. Is there a reason why `previous period` compa...
# gooddata-cloud
Hey. Is there a reason why
previous period
comparisons don't work within headline charts when an additional filter is present (like excluding days by by day of week)? For example - I set a static date (single day = 11/24) on my headline and enable compare with previous period. This works (pic 1). When I do the same but with an additional filter that excludes Sun & Sat it stops working. Why does it stop working, considering 11/24 is a Friday, thus previous period is Thursday, which doesn't touch the added filter?
Hi Filip, I have been testing this on my side and I have been trying to replicate this behaviour you’re experiencing. But I am not able to replicate this issue. When I create the same filter for my headline report, and add the additional filter that excludes Sun & Sat the insight is computed without issue - Please see my screenshots below which highlight this. As I am not able to replicate it, can I ask for the following details: • Can you please try and use a different date in the filter and see if the issue still persists? • Do you see any errors in your Dev tools related to this? • Lastly, it seems in your report that you have some custom formatting applied - As it’s showing both the percentage and value$ there in the same total. Can you please provide additional details or screenshots on this configuration you have applied in the insight so I can try and replicate it on my side? And does the issue still occur without this custom formatting applied?
@Michael Ullock 1. it happens on any date. 2. errors - yes tigershark throws backend errors. a. trace id: 028a154a29cbb689b3ca6f14a9dfc8f5 3. I have tried this with rounded numbers, issue still happens. 4. I also tried disabling
completely in the chart configuration - still getting the error.
Hi @Filip Charikov, thanks for double-checking this for me. In the meantime, I just received word that this seems to be related to an internal issue on our side. Our engineers are currently looking into this - Once I have more details on this, I will reach back out to you and let you know right away.
Hi @Filip Charikov, I was not able to simulate it on my model neither when I tried your approach. However, your requests are trying to do a datetime algebra on minute granularity with column of
datatype what BigQuery does not support. As a quick fix, you can convert
. Still it is unclear to me why the granularity of date is changed to minutes. Is it possible that you are somewhere working with minutes?
@Martin Cermak we have like 9 dates in the data model, some of them go down to seconds (TIMESTAMP I believe)
Should I just put every date as DATETIME then?
In this concrete case, the issue is caused by column
but yes, If you put DATETIME everywhere, you should be safe.
@Martin Cermak I did that for all fields and I get this now:
Copy code
"title": "Bad Request",
"status": 400,
"detail": "A result cache error has occurred during the calculation of the result",
"resultId": "2c4c4dda816f1e26e4cca5ca3966d530b0cb256b",
"reason": "Enumerating datetime attributes='[attribute/reviewed_date.day/zentist-main]' is not allowed",
"traceId": "585996d258c9570accd5977eb3c1a5ee"
Hi Filip. It seems that it is a different issue. This message is thrown in case when a report is trying to join or slice whole date dimension. The date dimension is infinite so such thing is not allowed. Can you please describe what are you trying to execute?
Ah I found the issue - it throws this error when only date field is in the chart. When I add other stuff it starts to work.
Perfect, I am happy to hear that. So everything works fine now?