Hi there, I have another question. I am loading da...
# gooddata-platform
Hi there, I have another question. I am loading data from Google Big Query and I am not able to load large decimals (floats). There is BQ column 'sessionsPlans' with type FLOAT (picture 1). It is a source for column 'Sessionsplans' with type DECIMAL in my GD model (picture 2). However, I am not able to load numbers, that have 8+ digits before decimal points. For example number 10419826.0 from BQ results in 1.04 - the number seems to been divided by 10 000 000 (pictures 3 and 4). As you can see, I tried to change the DECIMAL(12,2) to DECIMAL(50,2), but it hasn't helped. Numbers lower than 10 000 000 have been loaded correctly. Could you please help me how to load the data correctly? Thank you in advance.
Hi Karel, using data type decimal allows up to 15 digits, up to 6 digits after decimal point (implies 9 digits before decimal point). So you will need to set it to (15,6). This is shown in our platform limits here: https://support.gooddata.com/hc/en-us/articles/4407896389139#anchor_6
Hi, this is not the problem. It was by default (12,2), then I tried (15,2) and only at the end I tried (50,2). I do not need more digits after the decimal point, since there are only two of them. It looks I cannot load to GD more than 7 digits before the decimal point. To be sure, I have just tried (15,6) now, but it did not help...
Hi @Karel Nejman, this seems to be a bug and it is currently being investigated by our engineering team. The best way to work around this is to recast the
column to
in an intermediate view object.
Hi Marek, ok thank you.