# gooddata-ui
https://university.gooddata.com/gdui-starting-from-scratch-1/862670 I think I remember this GD University course showing examples of the gdc-catalog-export functionality. It appears to have been moved or taken down. Is that correct?
Hi Levi, Thank you for reporting this and sorry for the trouble. I will double-check this with our Education team.
Excellent. I have another question about the catalog export functionality that I've been unable to get a response on. https://gooddataconnect.slack.com/archives/C01UR5BGAHY/p1691015112591519 Any idea what is causing the error I'm encounting?
Sure thing. May I know what article are you referring to, please? Have you tried to follow these steps? https://sdk.gooddata.com/gooddata-ui/docs/gdc_catalog_export.html
Hmmmm while it looks very similar, the one I was using is a different URL: https://sdk.gooddata.com/gooddata-ui/docs/export_catalog.html How did you find your particular documentation?
I’ve simply used the first article from the search. But I have to admit, this is pretty strange. Looks like I will need to get in touch with our Documentation team as well, as per I would expect just one article with instructions under the certain SDK version. Once again, I am really sorry for the inconveniences.
👍 1
In either event, I looked through the article you sent. It appears to use a very similar approach: 1. .gdcatalogrc with my values 2. run
npx @goodatat/catalog-export
I get the same error referencing a local ip address. Note that I have swapped the hostname from our actual host name to
Sorry to hear so. Unfortunately, I am no expert in this field, but I will get one of our engineers involved as soon as possible.
👍 1
Hi there Levi, just to double-check, have you also included the "backend" parameter in your .gdcatalogrc? The default behavior of the export tool is to assume it's communicating with the GD platform if not specified otherwise.
Good suggestion, and yes, I believe I have. Here is the .gdcatalogrc file with some redacted information for security:
Copy code
  "hostname": "<http://example.cloud.gooddata.com|example.cloud.gooddata.com>",
  "workspaceId": "redacted workspace id",
  "catalogOutput": "catalog.js",
  "backend": "tiger",
  "token": "redacted token"
I have specified the backend as
I also submitted a ticket for this issue: #116005 If I understand correctly, the request was to bring it back to this slack channel so the engineers and developers could interact with my inquiry? @Radek Novacek how can I get some guidance on this issue?
Hi Levi, sorry for the delay! The parameters are correct and I'm still looking into this, let me come back to you promptly 🙂
So, one more thing from your setup - you mentioned you essentially made your own refresh-md since the docs mention it without specifying; can you share it as well? We can always move into private messages if you have anything you'd rather not share publicly of course.
And to add one more, since we're communicating on a bit of a different timezone, to avoid taking this one step at a time - could you try to run the GD catalog export with the hostname specified as a command line parameter? (as in
npx @gooddata/catalog-export --hostname <http://your.hostname.com|your.hostname.com>
I'll give that a try and get the answer to your questions
🤞 1
In case anyone else ends up running into the same issue, it's caused by
not being automatically included when trying to connect, and is resolved by including it in the hostname 🙂
👌 2