I'm having and issue with ReactIntl and its connec...
# gooddata-ui
I'm having and issue with ReactIntl and its connection with the AttributeFilter component, Does anyone ever had this problem?
Hi Gustavo, we rencently moved to a newer version of react-intl internally. This error looks like you might have duplicates in your dependencies. Please make sure that all the GoodData.UI packages in oyur package.json file are of the same version (that you are not mixing 8.6.0 and 8.7.0 for example). Also please make sure your yarn-lock or package-lock.json only contain one entry per
package, otherwise errors like this may happen.
Hi @Dan Homola We are facing the same issue Below are the package used
Copy code
"@gooddata/sdk-backend-tiger": "8.7.0",
    "@gooddata/sdk-model": "8.7.0",
    "@gooddata/sdk-ui": "8.7.0",
    "@gooddata/sdk-ui-charts": "8.7.0",
    "@gooddata/sdk-ui-ext": "8.7.0",
    "@gooddata/sdk-ui-filters": "8.7.0",
    "@gooddata/sdk-ui-geo": "8.7.0",
    "@gooddata/sdk-ui-pivot": "8.7.0",
Still it throwing the above error
Hi @Vatsal Trivedi using the pacakges without carets (like
"@gooddata/sdk-backend-tiger": "^8.7.0"
is problematic, because you will likely end up with more than one version of the GoodData packages in your bundle. If you check your yarn.lock or package-lock.json, you will most likely see more than one version of
there. This is know to cause problems. To get around this, either add carets to your package.json entries for ``@gooddata/` packages and running the installation again - this is what we recommend and also do in our applications. If that is not ok in your setup, you will probably need to use something like Yarn resolutions to force all the
packages to the same version, but that would make things a bit more complex to maintain, I would really recommend the carets.
Hi @Dan Homola 8.7 was hard coded by me as there were some breaking changes with 1.4 and 1.5 GDCN I will try with ^ and see Thanks
Oh, I did not realize that! Please see the compatibility table to see which versions of GoodData.UI are compatible with which versions of GoodData.CN. In case you need your application to “hold back” on the GoodData.UI upgrade, you will most likely need to resort to the Yarn resolutions I mentioned earlier explicitly specify all the
packages you find in your yarn.lock to the exact version you want to use. If you use npm, they have a similar functionality called overrides.