hello, I am trying to log into our workspace grey ...
# gd-beginners
hello, I am trying to log into our workspace grey pages (I am the administrator) so that I can try and set a custom date range in GD. The default range starts in 1900, but our data is only live from 2000. The page I am trying to access is https://secure.gooddata.com/gdc/md/{workspaceID}/datedimension/pull. I am logged in as normal and using my normal UID and password. However, this page refuses to let me into our account (see below). I do not use a mac so the
command does not work for me. The tutorial I am following is here: https://help.gooddata.com/doc/enterprise/en/dashboards-and-insights/manage-custom-date-dimensions/#ManageCustomDateDimensions-RunaLoadTask. The dateset I am trying to pull is this (attached).
note: I am pulling the workspace ID from the data integration console and pasting that hash into the {} in the URL above.
updated: apparently the start of the URL is wrong. This should be {your-GD-domain}/gdc/md/{workspaceID}/datedimension/pull
it would be helpful if the docs were updated to make this more explicit
Hi, @Hesseltje van Goor. I’m glad to see you were able to get the link to work! Note that the article you were following does have a section explaining how to replace the beginning of the URL in the way you mentioned (see my screenshot below). Please take a second look at it and let us know if you still feel it is easy to miss, so we can look into making it more explicit. 🙂
I think it's very easy to miss TBH 🙂 the bit I ended up referencing was this:
everything in this section was new to me (from working out how to use Cyberduck to fixing the CSV - so it's a lot of information that has to be processed all at once)
what's also not 100% clear is what you're meant to do once you get to to the DateDimension:MDDateDimension:Pull screen. I ended up replicating what I saw in the screenshot by typing this information in manually:
and then hitting submit. GD returns this:
but when I click the link it gives it throws an error:
I don't know what the error means or where to go from there. Or if any additional steps are required on my end.
That error message means that the Dataset you identified in the textbox,
was not found in your workspace. That happened because you used the example value. You need to insert the Object Identifier for the Date dataset you want to update from your workspace. You can locate this identifier through the graypages, using the URL `{your-GD-domain}/gdc/md/{workspaceID}/query/datasets`; select the Date dataset from the list there. You can then use the identifier under the section “identifier” in the DateDimention text box!
I see! Let me try that, one sec.
🤔 OK - so if I understand you correctly, I need to make a list of identifiers - one for every date I have here:
and the thing I am looking for is this:
from this particular example
let me try that
trying this now 🤞
Looking good so far! Let us know how it goes.
progress, new error here:
all I did was remove all the rows before 2005. No other changes were made.
The error message indicates problems with the CSV you uploaded. Please make sure that the CSV you edited contains all the columns specified in this section of the article https://help.gooddata.com/doc/enterprise/en/dashboards-and-insights/manage-custom-date-dimensions/#ManageCustomDateDimensions-UseYourOwnCalendar and that you removed the previous rows correctly (e.g., make sure that the first row in the csv is complete). Could you kindly share what’s the objective here? Why remove the years before 2005?
@Francisco Antunes I was advised that doing so would reduce the storage footprint for the date object on GD. As we don't actually need any dates before 2005, this seemed like a good thing to do.
Ah, I see! Thank you for the added context. Indeed, this will help with performance and storage footpring, especially in larger projects. Were you able to perform the update? Did you find any problems in the CSV?
🙂 I'm investigating now 🙂
👌 1
OK, it works with the default version 😁 so let me try and work out what broke when I changed that.
this makes no sense
all I am doing is deleting rows, the header 1 is in tact
would you have any tips for getting this to work? I don't understand why it would break if I am just deleting unnecessary rows
Thank you for the CSV, I will take a look and run some tests of my own.
thank you so much. To create that CSV, I deleted rows A2 to A38352 from the original one (in Excel) and saved (original attached).
Hi, @Hesseltje van Goor. I ran into the same error as you did when using the edited CSV you sent, so I checked it against the original one. I noticed that the format was a bit different. On the original CSV, when opened as a text file, each value is also between quotes (try opening the file on a text editor to see). Might be possible that exporting from Excel caused the change. So I took the original file and removed all dates before Jan 1st 2005 on a text editor, and uploaded it to my test environment. I was able to set it as the custom Calendar with no issues. I’m attaching the file here, please take a look. It should work on your environment too, if you’d like to use it.
🙌 1
I bow to you Francisco! Sounds like the comma separation was the difference then 🤔 it might be worth adding a note around this in the docs, so that people can keep an eye on it
I’m happy it’s working now! I will make a note about the article and the improvements you suggested, so we can discuss it internally. Thank you for the feedback :) If you have any other questions or issues, ask away and we’ll be glad to help!
🙌 2
btw - I had a quick look. I don't think there is a straightforward way to have excel mimic the GD date format, on Windows or Mac. GD's original files use
- which excel seems to simplify to
with disastrous results. There is an article on forcing excel to change the way it exports to csv here, but as you can see users aren't really given an option to explicitly set a format. They can only influence what Excel does by toggling things on and off. This means that your approach (manually deleting things in notepad) is probably the most robust approach available. It also means that in the absence of a spreadsheet program, most clients will be limited in the amount of customisation they can do, unless your dev team know of a reliable way to convert excel CSVs back to GD CSVs online? 🙂