Hello. I accidently deleted one fact in a dataset ...
# gd-beginners
Hello. I accidently deleted one fact in a dataset and it did not work when I tried to load it via keboola. Is there any option how I can load it back (grey pages or something else)? thanks a lot
Hi @Melánia Bachan Firkaľová, how did you delete the fact. Have you used “Delete” button in Manage section?
Hello Jakub. Yes I did.
The fact got flag
deprecated: "1"
. Such change can be undone via grey page in my opinion. Try to locate metadata object of the fact in grey page. I think it will be still referenced from metadata object of dataset.
1. Try to open the dataset in Manage and press
and then
. It should open grey page with metadata object of dataset. 2. Look for “facts” part of the metadata object and check which of the links points to the “deprecated” fact object. Open the grey page with the object 3. Add
to URL of the metadata object of the “deprecated” fact 4. Change line with
"deprecated" : "1",
"deprecated" : "0",
and submit the change. Let’s hope it will solve the problem.
👍 Thank you very much, it worked perfectly! The fact appeared back in the GD dataset but unfortunately with values of last 5 days only. Loading via Keboola did not help
Hi @Melánia Bachan Firkaľová, you would need to do a full load to see the historic data.
Hi @Moises Morales. Thank you.