Hey all, I'm having an issue with a new Snowflake ...
# gooddata-cloud
Hey all, I'm having an issue with a new Snowflake Datasource. Has anything changed recently regarding the schema connections/permissions?
Verified that the exact same permissions given to the role are the same between this environment and another parallel environnment. I cannot get it to show any tables
Ah nm figured it out. The default role wasn't set on the profile.
False alarm
Hi Steve - as you can tell by now there hasn’t been any changes in our support of Snowflake 😉 I’m happy to hear that you were able to figure it out, though! Feel free to post anytime you have issues or questions, and we’ll be happy to help you out with them 🙂
If the role was added to the snowflake configuration then this wouldn't be hidden
not saying it is a fix just saying that having to have the default role set to allow the connection to work is kind of a hidden setting. You have everything else: • Account • Database • Warehouse • Schema Add in Role and its all explicit
I see what you mean - I’ll be happy to mark it down as Product Feedback. Note, though, that it is already possible to connect using a non-default role in GoodData-Snowflake Integration Details, which can be done by appending
Copy code
to the data source’s Connection URL. Sorry, the above actually relates to GoodData Platform, not Cloud! Thanks for the feedback 🙂
🎉 New note created.