hey folks - what would cause values of an attribut...
# gooddata-cloud
j
hey folks - what would cause values of an attribute to be able to load when shown as rows, but fail to load when the same attribute is put as a filter?
This particular attribute was being used just fine as a filter yesterday as well, but today is failing to load values. Found it odd that data would show in rows but not load as a filter - I checked query logs on the data source and have no failed queries either 👀
f
That sure is strange. I can build a similar insight on my test environment with no issues, so it’s not a generalized problem. Were any changes done to the source data recently (adding or removing values or columns, etc)? Would you kindly grab a
traceId
of this error? It can be done from the Browser Console, it should be part of the error message from GD Cloud.
j
No recent changes to LDM or dataset and was working yesterday. See relevant console info:
f
Thanks for the info, Josh! I’ll investigate it from my end, check internally too. I’m not familiar with this particular error, so bear with me. Is this issue affecting only this single attribute?
j
Thank you, need this filter for a client dashboard. It is the only one I have seen today that is failing to load, but my datasets are large and I have no way to check them all.
i
Hi @Josh Kladis, Could you kindly try to reload your cached data as instructed here?
j
hi, yes i have reloaded the cache and it seems to have solved the issue for now. I still wonder why values would load in a row but not as a filter, assuming the cached data was the issue I would think it would fail to load everywhere.
f
Hi Josh! Happy to hear it worked out. From my understanding after checking the error logs, the Cache was failing specifically during the step of the Insight execution where it performs this API Call, which lists the available labels for filtering. In practice, it means that it was in a state where it’d fail for filters but not when loading a row.
Hi @Filip Charikov, we’d be happy to look into this. Would you mind posting about the issue directly on the #gooddata-cloud channel, so we can track it from our end?
1