Hi - I'm trying to connect to a new Snowflake DB, ...
# gooddata-platform
Hi - I'm trying to connect to a new Snowflake DB, but I'm getting the following error (see screenshot). I've made sure the user has all the rights outlined in the documentation here. I've also double-checked that I've entered all the information correctly. What else can I do to troubleshoot?
I grabbed the URL from the snowflake platform (screenshot below), and have verified in a separate browser that it is correct. I've formatted the connection URL like this: jdbc:snowflake://{url from snowflake with https:// removed} I've re-entered my username and password multiple times (by copy/pasting from a password manager to prevent user error). I've tried both upper and lowercase for database, warehouse and schema names. I've also tried to force the default role by adding ?role={role name} at the end of the connection URL (with the appropriate role name filled in... again I tried both upper and lower case)
Hi Mitchel, thank you for bringing this in. Based on the error message, there looks like there may be an issue with the URL. I tested, and the error message will tell you if the issue is with the Database or Schema, for example. Would you kindly share the actual connection URL with me, please? You can send it via direct messages.