Hello! I am facing an issue with ADDv2 - the sche...
# gooddata-platform
Hello! I am facing an issue with ADDv2 - the schedule errored out with
[ERROR]: Data distribution worker failed. Reason: Invalid segment uri
and I cannot run the schedule manually because it says "Failed to load LDM model." Additional info: • I was able to run the rollout, provision, and user bricks before that (manually, and also via schedule). • The segment configured in this process is same as in rollout/provision • I tried redeploying the ADDv2 process • No changes since running the bricks above • Configuration, full log in thread >>>> How can I solve this? Thanks!
Screen Shot 2022-05-05 at 1.21.11 PM.png
Copy code
2022-05-05T12:30:44.664+0200 [INFO]: Data distribution worker started
2022-05-05T12:30:44.664+0200 [INFO]: Request id: "hlXlWjgkOOWM1lP6"
2022-05-05T12:30:44.664+0200 [INFO]: Data source: "62730427a235280001c1fdf3"
2022-05-05T12:30:44.664+0200 [INFO]: Additional parameters: {GDC_DE_SYNCHRONIZE_ALL=true, PROCESS_ID=cd4ad629-ab04-4a3e-9ac4-28db5a63c27e, data_product=dataproduct_dso, gd_encoded_params={
  "segment_filter": ["segment_dso_default"],
  "technical_users": ["{{redacted}}", "{{redacted}}"]
}, organization=votresucces}
2022-05-05T12:30:44.664+0200 [INFO]: Synchronization mode: all mapped datasets (default)
2022-05-05T12:30:44.743+0200 [ERROR]: Data distribution worker failed. Reason: Invalid segment uri
Haven’t you use the pipeline export & import to migrate the ADDv2 to your production domain? I can see in our logs that you are trying to use segment called “>>FIXME<<” This is a special value used by the pipeline export/import feature for secure params, datasources and in case of ADDv2 also segments . The reason here is that segment technically contains in its link the name of the domain (which is different for each domain). So after the very first import of ADDv2 process using the pipeline import, you need to click “redeploy” button and select the proper segment which exists in your domain. Next time if you import the pipeline into already existing pipeline, the >>FIXME<< value will not override the existing values so this really only needs to be done once at the beginning.
That's weird though, as you can see in the logs the segment is clearly marked 'segment_dso_default'? All my parameters are defined - I don't see a FIXME; unless I'm not looking at the right place?
Did you do something? It suddenly doesn't display the LDM error
On my side an hour ago I deleted the gd_encoded_params and recreated it with the same value (copy-pasted). Besides that I haven't done any changes
Seems like a bug to me 😅
No, I did not touch a thing. BTW the ADDv2 process does not need gd_encoded params. All the main parameters (i.e. segment) are set in the deployment dialogue.
I redeployed two hours or so ago, but back then it still showed the same error Hmmmmm
I guess the deployment did it, but why it didn't update in UI is unknown to me