:wave: Hello, team! I have a field `MQL scores` co...
# gooddata-platform
👋 Hello, team! I have a field
MQL scores
containing integers. GoodData would like to load it as a fact. When I do this, the loading process works properly. However, when I then convert this field to an attribute, everything breaks. I would like to set this field to an attribute because I'd like to filter for values over 15 in one of my charts. Using the fact interface, I can sum, average, etc. but I can't seem to filter by
. Setting
MQL scores
to an attribute in the datamodel would fix this, insofar as I would then be able to just select which values I would want to see from a drop-down model. However, when I set this field to an attribute the system fails to load. What am I missing?
Hi Hesseltje, from our logs I can see the following error:
Copy code
An error occured during loading of csv files: SQLSTATE_INVALID_TEXT_REPRESENTATION_PG. Details: invalid input syntax for type integer: \"\"; invalid input syntax for type integer:
The INTEGER data type supports the null values, but not the empty string. Unfortunately, loading NULL values into attribute with numeric data type is not possible. Therefore, you’ll need to change the NULL for a zero or in the LDM change the label to text.
Thanks Michael, I'll try that now
Unfortunately it is still failing. I have set both fields to text:
I found a mismatch with the quality_score. Retrying. I wish this system had versioning for the model!
That was it!
besides versioning, would there be an option to make the console more specific when it describes the error, i.e. mentioning the name of the field it failed on in that final code?