Hello. On our site we are using the React Dashboar...
# gooddata-ui
Hello. On our site we are using the React Dashboard component to embed a dashboard with 1 insight. Inside of the insight, several cells have no value and
(empty value)
is being shown in them. This appears to come from the internal function emptyHeaderTitleFromIntl(). Is there a recommended way to override this functionality and show nothing for the cell's value? Thanks!
Hi Jon. This doesn’t actually come from the React SDK itself, but is part of the platform. (empty value) is substituted for null attributes even if you were to log into GoodData directly. The easiest way of dealing with this is replacing the null values by some custom value as part of ETL -> with some SQL script that you’d run over the source data before uploading it.
I disagree. The network responses come in with
values. Also when I modify the source code for that function, my changes are reflected in the insight.
Hi, the functionality cannot be overridden by a config, but you could use the measure formatting to replace the empty values with some other value (a space for example). See the following format for an example
Copy code
[=NULL] ;
notice the space between
See more information about the formatting here: • GoodData Cloud and Cloud Native: https://www.gooddata.com/developers/cloud-native/doc/cloud/create-metrics/format-numbers/ • GoodData Platform: https://help.gooddata.com/pages/viewpage.action?pageId=107721568
My bad, Jon. I wasn’t aware that this was an option 😐
No worries, thanks for the info