Solved

Application created using Accelerator Toolkit keeps refreshing

  • 12 July 2022
  • 3 replies
  • 40 views

I created a react application using the Accelerator toolkit and following this tutorial https://university.gooddata.com/gdui-starting-from-scratch-1

I am using a GoodData.CN instance. 

After installing dependencies using ‘yarn install’ I ran the application using ‘yarn start’.

The application launched and the Welcome page opened but the page kept reloading continuously. By debugging a bit I found that the useEffect in AuthProvider in context.js causes this continuous refresh.

useEffect(() => {
const auth = async () => {
try {
await backend.authenticate();
onLoginSuccess();
} catch (err) {
// we do not care about the error in this context
onLoginError({});
}
};

auth();
// eslint-disable-next-line react-hooks/exhaustive-deps
}, []);

Am I missing any settings in my GoodData.CN instance?

icon

Best answer by jacek 13 July 2022, 17:51

View original

3 replies

Userlevel 2

Hi Aaron,

I just tried to reproduce your issue:

  • I started GoodData.CN Community Edition from the gooddata/gooddata-cn-ce:1.7.2 image
  • I executed 
    npx @gooddata/create-gooddata-react-app --backend tiger
  • I named the application “demo”, set “http://localhost:3000” as hostname, and set “typescript” as language
  • cd demo
  • yarn start
  • A new tab was opened in my browser waiting for the application to start
  • Because I did not log in into GoodData.CN in my browser before, once the application started successfully, the related browser tab redirected to URL like this: “http://localhost:3000/dex/auth/local?req=pxnwqfthq2jzwkhc56gfxvoc6
  • Once I logged in, I was redirected back to the Welcome page of the React app 

So everything seems to be working properly.

Do you use the Community Edition or the helm chart deployment?

What version of GoodData.CN do you use?

 

 

I am used the community edition. I have deployed it as a docker container on Azure using AKS (Azure Kubernetes Services). I am able to login to the GoodData application without any issues.  It’s only the react application that was built using the toolkit that is having this issue

I don’t remember the GoodData version. Is there a way to retrieve it from the browser?

I used the JavaScript template when generating the application code.

Userlevel 2

Unfortunately, it is not possible to set up CORS in the community edition yet and this is exactly what you need in this case.

We identified this limitation as important and prepared a fix - in future versions it will be possible to set up CORS both through API and UI. The fix will be a part of next releases:

  • Community Edition - use docker tag dev_latest to get it now or wait for the next major release, no release date set yet
  • Helm chart - wait for the next major release, no release date set yet
  • a new SaaS offering - going to be released in upcoming days, including free trial, first only in AWS

Reply