Release Notes - GoodData Platform

GoodData Platform - April 22, 2021

Related products: GoodData Platform
  • 22 April 2021
  • 0 replies
  • 13 views

GoodData.UI Version 8.3 Available: Support for GoodData.CN

We have released Version 8.3 of GoodData.UI, our powerful library for building analytical applications powered by GoodData.

New in this version: Support for GoodData.CN
Version 8.3 introduces support for GoodData Cloud Native (GoodData.CN), our brand-new cloud-native analytics service that you can deploy and connect directly to your data warehouse.
For more information about integration of GoodData.UI and GoodData.CN, see this article.

 

Use Google Service Account Key File to Connect to BigQuery

You can now easily connect your GoodData workspace with a BigQuery datasource by uploading a Google service account key file during the integration process.

Just drop the service account key file onto the dialog and the GoodData connector will extract the information necessary to authenticate your account and establish the connection.

To learn more about how the process works, including which information are used, refer to our documentation.

You can always provide the required details manually.

 

REMINDER: Upgrade Your GoodData.UI to Version 8.x

Version 7.x of GoodData.UI reached its end-of-development, and it is now in maintenance mode until March 31, 2022, when it will reach its end-of-support. The versions older than Version 7.x are no longer supported.

How does it affect you?
You are affected if you are using a version of GoodData.UI older than Version 8.x.

ACTION REQUIRED!
Upgrade your GoodData.UI to Version 8.x. We recommend that you do so as soon as possible.

  1. Review the breaking changes in Version 8.0.
  2. Follow our step-by-step Migration Guide that will walk you through the migration process.

What will happen if you do not upgrade to Version 8.x?
When Version 7.x reaches its end-of-support, it will receive neither new features nor bug fixes. No technical support will be provided. Although the version will still be available for use, we do not recommend that you use it.

Learn more:
To learn more about how different versions of GoodData.UI go through the life cycle phases and what level of support you can expect when using a specific version, see Supported Versions.

 

REMINDER: Use TLS Version 1.2 or Higher Only

Support for Transport Layer Security (TLS) version 1.0 and 1.1 is deprecated and will end in one of future releases. We will announce the exact date as soon as it is set.

How will this affect you?
All modern web browsers and programming languages already support the newer versions of TLS (1.2 and higher). Unless you use obsolete software or unsupported systems, you are not affected.

You may be affected if you are using an older version of the libraries or programming languages in your tools. To verify, check the documentation for your tool:

ACTION REQUIRED!
Make sure that all your components and integrations use TLS version 1.2 or higher.

What will happen if you do not upgrade to the newer versions?
When support for TLS version 1.0 and 1.1 ends, if you do not switch to a newer version of TLS, the integration with the GoodData platform will stop working.

Learn more: