Question

Determine attribute value id - url link doesn't work

  • 18 November 2021
  • 5 replies
  • 67 views

Hello,

 

I am following the instructions here to try to find the attribute value id for some attributes in my dashboard, such that I can add in data permissions.

 

The link that it sends me to find the attribute value id doesn’t work, I have followed all instructions and replaced the ‘secure’ part with the white-label name that my company uses.

 

I used the link last week, and it worked fine. This week it does not, and redirects me immediately away from the site.

The link is: 

https://secure.gooddata.com/labs/apps/ui-developer-toolkit/build/index.html#/metadata

How can I solve this issue? I need to find the attribute value id as I need to set user permissions as a matter of urgency.

 

Best,

Courtney


5 replies

Userlevel 1

Hi Courtney, 

 

The reason the link is no longer working is that the interface that allowed you to get this info has been deprecated. You will have to use the project Grey Pages instead by navigating to: https://[domain]/gdc/md/[WID]/ (WID = Workspace ID) > query > attributes. In this page, you will have to click the link in the “elements” variable. 

Let us know how you get on. 

 

Regards, 

 

-Moises

 

 

Hey, thanks for coming back to me so quickly.

 

I’ve managed to find the attribute value id from Grey Pages - however I’m now struggling to set a user permission.

 

In the instructions it says to use the following structure on this page https://secure.gooddata.com/gdc/md/{workspace_id}/obj

{
"userFilter": {
"content": {
"expression": "{data_permission_expression_statement}"
},
"meta": {
"category": "userFilter",
"title": "{data_permission_name}"
}
}
}

My data permission expression statements seems to be fine, but I keep getting an error when setting a data permission name as a string. The error I get it is 

"Storing string values of attributeDisplayForm is not allowed."

Last week when I successfully set user permissions, I was able to use a string e.g.

 

{
"userFilter": {
"content": {
"expression": "{my_data_permission_statement}"
},
"meta": {
"category": "userFilter",
"title": "{my_string}"
}
}
}

 

The meta section is compulsory. How should I fill this out?

 

Best,

Courtney

Userlevel 1

Hi Courney, 

 

I believe the error refers to the fact that your Data Permission syntax may not be correct, although it is hard to say for certain without looking at it. Can you please double check? 

 

It should look like one of these: 

[attribute_uri] = [attribute_value_uri]

[attribute_uri] <> [attribute_value_uri]

[attribute_uri] IN ( [attribute_value_1_uri], [attribute_value_2_uri], ... )

[attribute_uri] NOT IN ( [attribute_value_1_uri], [attribute_value_2_uri], ... )

[attribute_1_uri] = [attribute_1_value_uri] AND [attribute_2_uri] = [attribute_2_value_uri]
( [attribute_1_uri] = [attribute_1_value_uri] ) AND ( [attribute_2_uri] = [attribute_2_value_uri] )

 

You can also use the grey pages to create it: 

https://[your domain]/gdc/md/{workspace_id}/obj

 

And assign it to users: 

https://[your domain]/gdc/md/{workspace_id}/userfilters

 

Best regards, 

 

-Moises

 

Hello,

I am using the interface at https://[your domain]/gdc/md/{workspace_id}/obj (see attached screenshot).

 

When I submit the data as shown in the screenshot I receive the following error:

{   "error" : {      "component" : "GDC::Grammar::MAQL::AST::StringCollection",      "errorClass" : "GDC::Exception::User",      "message" : "Storing string values of attributeDisplayForm is not allowed.",      "parameters" : [],      "requestId" : "OLsVieQsQK2GJ5HF:8vyqghqyyoey1p0o"   }}

 

Please can you let me know what my error is?

 

Best,
Courtney

Userlevel 1

Hi Courtney, 

 

It looks like you are using the value for "attributeDisplayForm" as the object URI. Can you please make sure you are actually using the value for "attribute" or uri" (found in the attribute metadata main page)?

 

Let me know how you get on. 

 

-Moises

Reply