Solved

There are no tables in the database while connecting to Snowflake DB

  • 15 March 2023
  • 8 replies
  • 126 views

Hey GoodData team,

 

I am trying to connect to snowflake from GoodData as a data source. I have successfully connected the two, but not getting any tables in our schema. What could be the problem here, I’ve tried the following Schema Names while connecting: 

`OP_DEV, PUBLIC, INFORMATION_SCHEMA, op_dev, public, information_schema `

 

All of them show the same error “There are no tables in the database”. Could you help me out on this, as we’ve been trying to get GoodData and snowflake running for a while now, thank you. 

 

 

 

 

icon

Best answer by Joseph Heun 17 March 2023, 09:23

View original

8 replies

Userlevel 3

Hello, I’m going to open a private ticket and will reach out to the both of you through the ticket/email shortly. 

Userlevel 3

There are two steps when configuring your Snowflake Database with GoodData. First, you must configure the user access rights, and then you can create the snowflake datasource instance. Could you please follow the steps in the documentation HERE, and let us know if you get stuck or experience the same issue with missing tables?

Hey Joseph, 
 

We have followed the steps to provide user access rights again, previously the rights were already provided to a role we have called “Developer”, and when I tested it again, nothing changed. It is giving me the same issue with the missing tables, and we have confirmation that the account being used has all the required access rights. Could you look into what the problem could be otherwise? thank you 

Userlevel 3

It looks like it could be an issue with how you have set up the tables and configured your user within Snowflake. However, it’s a bit difficult to ascertain without seeing everything you have configured there. Could you show us the permission setting for the user you are connecting with?

The user we are trying to sign in with has the role of DEVELOPER, the role DEVELOPER itself has access to the database ( we are connecting to) and all tables / views inside it. We have also set the default ROLE of the user as DEVELOPER. I’ve asked out data team to provide some permission settings to show that we have provided the access required to scan for tables. 

 

We have also followed the instructions above and provided all access written in the documentation.

I’ve talked to the data team and they are not comfortable sharing Databased details on a public forum, is there a way we can create private tickets or if you could provide an email we can send over the confidential information of the db access and schema? thanks

 

It looks like it could be an issue with how you have set up the tables and configured your user within Snowflake. However, it’s a bit difficult to ascertain without seeing everything you have configured there. Could you show us the permission setting for the user you are connecting with?

 

Hi Joseph, I’m the DBA for the Snowflake database in question. The user we are using for the connection has default role “developer” and the “developer” role has *all* permissions on the schema he’s trying to connect to. Using the “developer” role in the Snowflake web environment allows us to select and modify all tables in all schemas in the database we’re attempting to reach. I’m positive that this user’s default role has the permissions needed to access these tables. It must be something else.

Userlevel 2

Hello,

Let me also post the resolution here:

Snowflake environments default to "quoted_identifiers_ignore_case" - variables could be named without considering case. However because GoodData requires that "quoted_identifiers_ignore_case" is set to False in order to connect, the user we were logging in as wasn't being properly assigned the role "developer" because in the Snowflake environment the role is named "DEVELOPER".

 

Many thanks!

Boris from GoodData Support team

Reply