New Data button vs. Load Button

  • 28 January 2021
  • 14 replies

In the January 15th dashboard release, the “Load” button for the Good Data dashboard was changed to “Data” and now there isn’t any way to see my previous uploads from CSV to my dashboard and when I try using the new “Load” function, I get error messages that the data already exists and can’t be updated or replaced.


It looks like I need to rebuild everything, including all my insights, from scratch to make this work again.


Am I the only one here that was uploading from CSV files to the dashboard and having insights attached to those CSV uploads in the past but now have issues with uploading after the January 15th software release?





Best answer by Andrey 5 February 2021, 17:11

View original

14 replies

Userlevel 2

Hey Seth,

Sorry to hear about your troubles!

When you navigate to "Data" and then to "Load", you should see two sections there - Scheduled Loads and Datasets Loads.
You should see your historical loads under the Datasets Loads section. Please try to choose your dataset and then click on the button "Update from file". You can even download the "CSV template" if you are unsure of the correct structure.

You can also check the Load configuration of each Dataset directly from your Model. You just need to switch to the Edit mode, select your Dataset and in the bottom menu, click on More … button. Then please navigate to View details and switch to the Load configuration tab.

I believe that you can find some hints in our documentation as well.



     When I navigate to "Data" and then to "Load", there is only one section, Scheduled Loads, there is not a section for Dataset Loads. Please see the screenshot attached to this image.


     As for model, there weren’t any models built by me, unless the system built them automatically, therefore there also isn’t any Edit mode for models that are not visible.


Thank you for your attention to my situation. It is greatly appreciated.



Userlevel 2

May I know what User role has your user assigned within the project, please?
If there was any model published correctly to the Project, it should be visible to any Editor/Admin and editable for any Admin within the project.



     I am listed as the administrator of the project, if I am looking in the right place, see attachment. Thanks for your help.



Also, there is a data model visible if I navigate to Manage, Data tab, and click on Model under the project. I have attached a screenshot of that. But there is not a data model when I navigate to Data. It shows a Create model, button, but it doesn’t show the models that are visible under the Manage function and nor does it have a means to update those CSV files anymore under a section called Dataset Loads.


Your assistance is greatly appreciated.




Userlevel 2

Thank you very much for the attachment and all the details. Now I see what's going on here.

The Model available directly under the Manage section is usually used just for the quick check and review of existing model.

But if you'd like to manage your model, you'll need to access it via DISC(Data Integration Console) and then click on the Model on the top. The LDM Modeler interface opens and you should be able to edit it from here.




When I open the Data Integration Console, there aren’t any models listed under this project ID and when I click on Deploy Process, it still doesn’t show me the CSV file uploads that I was updating previously under the data sources.


I have attached screenshots of these two screens to this message.


Thank you for your assistance. 



Userlevel 2

Please check the top menu tabs/buttons.


The first one is for Model data and the second one stands for Load data. We need to use the first one.




     This Model data button takes me back to this “bring meaning to data” screen which asks me to create model again. If I click on Create model, then click on Sources, it shows me options to upload from Snowflake, AWS or CSV File. If I click on CSV File, then it takes me to the upload window where I upload a previously uploaded test CSV file, then the only option that is available is to create a new dataset, I click on Import and then click on Publish and then choose to replace existing data and then I get a Publishing failed error message because objects already exist in metadata.


I have tried to attach attachments that shows screenshots of each of these steps.


How can I find my previously uploaded CSV files and update them with a newer version that contains new data for my existing insights after the January 15th platform release?


Thank you very much for all the help that you are providing. It is most helpful and I am very grateful!

Hi Seth,

I was in touch with our Product team and I sent you a message from original ticket. Please review the model in your project and let me know if my manual update in the project helped. The datasets should be fully visible.

Best Regards,


@Jakub @Iva Gasparekova 


Thank you very much Jakub! I can now see and update my old CSV uploads. The column names have completely changed with adding underscores and letters before the column names, which is completely fine, but one column name for the PAS CSV upload sheet is different from the Bryan Tablet Data.

It is the serial number column. In the Bryan Tablet data CSV upload, it is called "a__s_n" but in the PAS CSV file, it is called “f__s_n”.

I get these column names when use the tool "to download a CSV template" before updating the CSV with the appropriate data.

How can I rename one of these column headers in GoodData so that they both use the same header name just like all the other column headings?

The reason I have two identical CSV uploads is because one of them filters the data first based upon a numeric value in Excel and the other one does not filter that same data. GoodData doesn't appear to offer the ability to filter the data based upon a numerical data value, only based upon dates or textual values.

I would like to use a numerical filter on the insights that only graph the rows that have a value greater than or equal to 100 for one of the columns, but there doesn't appear to be a way to do this.


Thanks for your help.





After uploading my updated CSV files using the new dataset updater that didn’t exist before the January 15th release, it removed/broke all my insights and KPI’s, I suspect because all the column names changed, and now our organization is deciding whether we want to continue using Good Data in the future. I have removed all the datasets that were previously used and a decision will be made whether to re-design everything again.


Thanks for your help,


Hi Seth,

I am very sorry to hear that. With the removed datasets now it is hard to confirm what exactly happened. (Usually I suggest a restore of the project to previous state but it is not part of the freemium offering) Since you are planning to use it long term maybe the rebuild and consideration of full logical data model (not just ad-hoc csv uploads for short term analysis) would make more sense.

Our Product team is informed about your case so be assured your feedback is heard. 


And pls allow me to add few words on previous comment. The way how we map the source columns in the modeller and differ between attributes and facts is explained in this doc. (Basically to fully achieve the capabilities of the product you want to always prepare the model (connect all the datasets) and datasources and build the insights on it.) Outside of freemium we also offer backup/restores in case the customer need an urgent rollback to previous state.

There are also many capabilities for advanced filtering thanks to the way how we define and use the measures and MAQL in general. We do not try to replace Excel but you should not need an additional duplicate CSV maybe just an additional data in your dataset. Just an example how you can work with measures here but that is just the top of the mountain.


I hope you reconsider.



Hello Seth,

Andrey from Product team there. 

It’s sad to learn that the recent update brought you such troubles, allow me to apologise for the inconvenience caused and I can assure you this wasn’t intended. When looking into this issue, we have found that you were one of few people using our platform in a very specific way that doesn’t utilise core values GoodData Platform provide to our customers. 

GoodData platform is there to empower our users to

  • Load and update data from data warehouses by schedule
  • Build context-aware metrics by utilising logical data model connecting logically coupled datasets
  • Create embeddable interactive insights and dashboards 

and most of these values were inaccessible in the way your workspaces were set up previously. The reason for that is use of now deprecated tool for ad-hoc analysis of CSV files that you were using. Structures created by it weren’t connected to the main data model of a workspace.

To turn the situation around I would recommend you to start with building logical data model by importing or drag-and-dropping your CSV file(s). You can do that in the Data section of a workspace introduced in this update. Experience should be quite similar to what you were used to before. First time you import the file data from it will be loaded to the dataset during publishing, following that please go to Load application to refresh data contents manually or from some cloud source. Having logical data model will create a stable structure to load your data regardless the source. If you would like to expand your data by some more related data points, you can append the data model with more datasets and connect them one to another, so the data from one can be used in another referenced by primary key.

This wouldn’t bring the visualisation (insights) you had created previously though, and you still will have to build them from scratch however you will now have a good base to build on that is future-proof.

I hope this helps and we would continue our cooperation.

Best regards,