Solved

Issues with connecting to Snowflake DB

  • 7 March 2023
  • 9 replies
  • 110 views

Hi GoodData,

 

I are having issues with connecting our Gooddata with snowflake as a data source. Following is the error that pops up whenever I are trying to connect, the credentials are all correct I have verified it multiple times. If I change the credentials, it gives me an error about invalid url.

Could you help us out on this issue?

 

 

Thanks and Regards,

Umer Nasir

icon

Best answer by Jan Kos 14 March 2023, 16:20

View original

9 replies

Userlevel 2

Hi Umer,

Can you please send us a trace ID of the error you are seeing from the browser dev tools?

Thank you.

Jan

Hey Jan, I can’t find the trace ID of the error anywhere, the only thing being returned in response is this, and the status code is 200.

error: "Unexpected column name returned: RESULT != \"result\"" 
successful: false

 

 

Userlevel 2

This is certainly strange error. If you try to connect to the datasource from the Logical Data Model in Data section, do you still see the error? Can you give mi approx. timestamp (with timezone) when you tried to connect to the datasource and encountered the error? I will check our logs.

Thanks.

Hey Jan,

 

I have tried to connect to the data source from the LDM in Data section and it gives me the same error. Also the time I tried it was:

8:47 pm

Wednesday, 8 March 2023

Pacific Time (PT)

 

 

Thank you.

 

Userlevel 2

Hi Umer,

Thanks for the details. The issue is when GoodData is establishing connection to the datasource, a test functionality is triggered as one of the necessary steps that executes 

SELECT 'success' as "result"

statement in datasource and instead of column name "result" the database returns "RESULT". This check is case sensitive and we are expecting "result" in lower case. I believe it comes from the fact that you have QUOTED_IDENTIFIERS_IGNORE_CASE parameter set to true on the account/database/user. You should be able to connect to the Snowflake if you disable the parameter.
 

We are discussing internally how we’ll be handling case sensitivity when establishing connection to datasources.
-Jan

Hi Jan, 

We have checked our snowflake db, and the QUOTED_IDENTIFIERS_IGNORE_CASE parameter was by default set to false. We have checked this for account/database/user and all of them have it set as default, and the issue is still persisting.

Could you kindly guide us on how to resolve this issue, as we have been trying to integrate GoodData with out application for weeks now to no avail. Thank you,

-Umer 

FYI, this ticket is not solved yet, could you mark this accordingly, thank you. 

Userlevel 2

Hi Umer,

I’ve adjusted the thread.

The parameter can be set on session level, have you tried checking that?

-Jan

Hi Jan, we just waited on it and now it works, I guess it might be session level, and setting it to false

Reply