Deleting a record in dataset

  • 5 January 2022
  • 3 replies

I am trying to delete 1 record and I have run into some problem. When trying to delete a record in the Spending dataset where the order no is = 2021_6734. According to the documentation the query should look something like this to delete the facts:


DELETE FROM {attr.spending.factsof} WHERE {} = "2021_6734";

When I am running the delete statement I am getting the following error: 

"error" : {

"component" : "DJG",

"errorClass" : "GDC::Exception::User",

"message" : "Object \"%s\" doesn't exist.",

"parameters" : [



"requestId" : "hjUDGKYxIf3OuhS:7txqnamxk997mgy0"




Which object does not exist? I am not sure what the issue is there? 


Best answer by Michael Ullock 5 January 2022, 15:36

View original

3 replies

I found the solve for my issue. In this table we have a PK jsou we don't have any factsof attribute. So I used a  ID attribute and  it was solved. 



Hi Michael,

I have the same problem as Samantha, I find the identifiers through Gray Pages so it have to work (I have an Admin role) But it doesn't help. I need to delete some data from the dataset by date (old data)  used the condition

``` DELETE FROM {attr._identifier of the dataset_.factsof} WHERE {_identifier of the date} between "2021-11-01" AND "2021-11-30";``` 


Please can you help me with it?


With respect,


Userlevel 2

Hi Samantha,

thanks for reaching out, we'll be happy to help with this.

From our logs, we can see the same error as you have reported:

exception_msg="Object \"attr.spending.factsof\" doesn't exist." project="byanfpis31ycd38qpyer1yg3cy8ng5ne" auth_user="4783ncv55abe88e3b87c32a48c06d4" request_id=hjUDGKYxIf3OuhS:7txqnamxk997mgy0

As the errors states, you're trying to delete records from an object that doesn't exist: attr.spending.factsof

Please refer to the following article that will help you find the correct object identifier:

Best regards,