Solved

How a user can change its language

  • 10 March 2023
  • 7 replies
  • 101 views

Hello,

How can a user change its language ? I cannot find the option anymore in the “Account” page.

 

 

It used to be here (see picuture in our user documentation) but I cannot find it anymore... Is there another way to do this ? I need that my users see Good Data in french.

66DFtkMZbSAhcmNVH5h5gN-s1a3KzrGf5-6LY_1c8_3KQ4tNKjKpyUgNZWwJR4Njsx1_DvEQwTQ7YpkN1LJ-tNZOeuddCbe499Vy9HJ1UauctGkcLAItk6B6PzrRAUyr9CsGV6VHptb3MhQwmbLXzQ

 

This support link seems to indicate that a platform setting is required. But I do not find anything for this.

 

Thanks in advance and Best Regards

icon

Best answer by Moises Morales 10 March 2023, 16:45

View original

7 replies

Userlevel 3

Note: The setting was turned on in the domain and Jacob confirmed everything is OK.

Hello,

 

I just see that the request is tagged as “solved”, but I’m still not able to set language for My user.

 

I really need help to solve this issue because our customer cannot go to production with English settings.

 

Best regard

Userlevel 3

I sent you a PM.

Hello Again,

I don’t know whats wrong with my endpoint. 

https://iwe.na.gooddata.com/gdc/domains/pjj8p/config display all domain config:

 

If I use a documented paramerter in the url (ie https://iwe.na.gooddata.com/gdc/domains/pjj8p/config/selectedUiTheme) I can change the setting:

But with the enableChangeLanguage (which is not documented in provided documentation), it doesn’t work.

I have the same error at project level: https://iwe.na.gooddata.com/gdc/projects/wpyw55yw2w339g16u55b676s2rf4o8u2/config/enableChangeLanguage

Best

Userlevel 3

Hi Nicolas, 
It looks like you are using the wrong endpoint. Please follow the steps here: Configure Various Features via Platform Settings | GoodData Enterprise

Best, 

-Moises

Hi Moises, 

Thanks for the quick reply ! Unfortunately, I thinks our domain has a problem … For other parameters, I can see an edit form.

https://iwe.na.gooddata.com/gdc/domains/pjj8p/config/enableChangeLanguage

Cheers

Userlevel 3

You may need to enable the platform setting for the user/domain: 

Navigate to

 https://{your.domain.com}/gdc/domains/{domain_name}/config

There you can see a list of available platfom settings. Using the interface at the bottom  you can specify the requested platform setting to add or update.  In this case enableChangeLanguage , set the value to true  and then hit submit

When you go to the account settings again, you will see the change language option.

 

-Moises

Reply